Home Support Symphony Pro

Lost File - can it be gotten back?

edited November -1 in Symphony Pro
Hey gang,

I had started a new file yesterday, filled in title author etc. And put in a lot of work saving every few minutes. I know for sure I was saving. Now when I open SPro it's opening a blank new file and my piece from yesterday is not in the file list.
Can I recover yesterday's file?
What could have caused this so we can avoid it?

I had emailed it to myself yesterday, but now when I checked it was not in my mail, and it looks like *maybe* the last file I worked on was the file actually sent. In any case I can't find yesterday's work, any ideas are welcome.

Much appreciated!


  • Options
    Just tested it with the same title composer track set up put in one note and saved. Switched files and the new one is not there again.

    Are there forbidden characters for the meta data that coils break it? The title I used has a "/" in it.

    Will try another test but would really love to get my old file back if it's possible.

  • Options
    It looks like a bug. The forward slash character could be the cause of the problem. On most operating systems, the "/" character is a path separator, so saving a file with it could cause the it to be saved somewhere it shouldn't.

    Even though the file is not shown in the File chooser view, it does not mean the file no longer exists. I have a feeling that the file is still on the device, but in a subdirectory of the main Documents folder. You might be able to recover it in the next update using iTunes File Sharing, which lets you access files straight from the device.

    I'll look into it.
  • Options
    This is a confirmed bug.

    The app allows you to have a "/" char in the title. When saving, the app fails to write the file out to the disk, but it never gives a warning that the save failed, making it appear as if it was successful.

    When I tried exporting the file, an alert is displayed, indicating there was a problem. We check to see if the file exists first before continuing so I'm not sure how you were able to export the file, since the file is not on the disk.

    Either way, the file you were working on is lost and unrecoverable. Sorry about that.

    We'll be adding a fix for this in the next update. Expect it in a couple of days.

    Lastly, thanks for documenting the steps to recreate and reporting it to us. It makes it so much easier for us to figure out what's wrong and how to fix it.
  • Options
    Knowing you found the bug makes me feel better and makes up for the loss. I really depend on this app already and I'm glad I remembered my good habits. "documenting the steps to recreate" is something I ask of my testers all the time and have to admit it's easy to forget when you are the USER.

    I REALLY appreciate you following this forum and being so proactive on the fixes. Can't wait for the updates and next version!

    all the best,
Sign In or Register to comment.